About:

The x79 DMG has been updated with USB fixes for Mac OS X 10.11 including USB 3.0. If you need to use USB 3.0 in a production environment then we would strongly recommend using 3rd party card that is natively supported. We will be adding a section regarding USB in general soon where we will list recommended cards and benefits over other cards.

We are also still looking for dedicated writers to help us continue to keep are guides up to date. If you are interested please contact us at: AKern@RampageDev.com

19 Comments on "x79 DMG Updated"

  1. Awesome, I’ll try it out now and let you know how it goes.

    I do have USB 3.0 working but it has issues such as it wont do full speed unless I plug in then remove and plug in to another port.

    If I boot up with something connected it works fine though but it will be nice to get it 100% working.

    I did get the Inateck Pci-e Card KT4004 last week but its conflicting with other PCI cards installed and I don’t have other slots to try since both my GPUs take up 3 lanes each.

    Reply
  2. Thanks man!

    Reply
  3. Awesome! Updating now!

    Reply
  4. Great Andrew! Thank you! Your post sorta suggest that your fix may not be reliable? Or do you mean that we should be using boards where the USB 3.0 is integrated into the chipset as opposed to boards that use the fresco chip for example?

    Reply
    • Um… there is no USB 3.0 on the x79 Chipset. The fix is for Native USB which in regards to x79 would be USB 2.0 only. What I was referring to was onboard 3rd party USB. Sorry for the confusion.

      Reply
  5. Hey, so I tried to install El Capitan by upgrading, today. It was quite a hassle because I kept getting a screen with the grey + beachball, but then I applied the RtVariables fix to config.plist as well as inserting the basic kexts into the /10.11 folder. This got the install going enough for me to be able to install El Cap.

    Once it finished installing, I cleaned up the EFI by configuring everything to the 10.11 Post Install from x79.dmg.

    However, now I can’t get Nvidia Web Drivers running at all. I can install them, I can boot using the regular OS X Drivers, but when I boot with nv_driver=1 it doesn’t active them and simply boots with default drivers, and when I boot with nada_drv=1 it simply crashes.

    Using a P9x79 Pro
    3930K
    GTX 980

    Everything worked perfectly in Yosemite.

    Reply
    • Check IOREG for the drivers. Chances are they are loaded as you did NOT read the install guide for the Nvidia Drivers which says the menu is cosmetic.

      Reply
      • Finally got everything working. It seems that using the MacPro 6,1 smbios was what was preventing Nvidia Drivers from working. I simply switched 6,1 to 5,1 in the Clover boot options. Was there a reason for the switch to 6,1 for X79 mobos?

        Reply
        • Works 100% for me under Mac Pro 6,1. Hit me up on Skype and we can get to the root cause. Chances are you did not edit the kext for what profile is loaded.

    • Also which variables did you have to add? Odd that you had to add any.

      Reply
  6. Hello, is there any info on Gigabyte’s G1.Assassin 2? Thanks

    Reply
  7. My apologies, I’d like to check my assumptions.
    I have an ASUS Rampage IV Black Edition motherboard, with the x79 chipset. According to the manual, the on-board USB ports are:
    Intel X79 Chipset:- 10x USB 2.0/1.1 ports ; 2 x USB 2.0 ports
    ASMedia: USB 3.0 SuperSpeed USB HUB Controller: – 8 x USB 3.0/2.0 ports.
    This hackintosh starts with Clover 1946, and runs OS X10.10. Most everything works. I have not yet tried to upgrade to OSX 10.11.
    ) If I install this new x79 DMG, and upgrade to 10.11, what USB functionality can I expect to work on my motherboard?
    ) Are you recommending that I purchase an additional PCIe USB 3.0 expansion card, to get working USB 3.0 ?
    ) Are you recommending that I choose a card that is already supported by Apple OSx 10.11 drivers?

    Thanks for the help and great work!

    Reply
    • The SSDT in the DMG address the x79 chipset USB which now fully works under Mac OS X 10.11.

      We have a updated USB 3.0 driver on the DMG which enabled onboard USB 3.0 however there may be issues in performance that people can not deal with due to production requirements. If it is below par then buy a supported USB 3.0 card.

      Reply
  8. Hi Andrew,
    I am running 10.9.5 with V.2.1 SSDT on ASUS P9X79-E WS.

    1) Are there any improvements for OS’s below 10.11?

    I noticed that SMBIOS changes to MacPro6,1 with the new V3.0 SSDT disabling Bresink HW Monitor under Mavericks.

    2) Can I change back to MacPro5,1 without issues?

    Many thanks!

    Reply
  9. Hello,

    can i use the DMG for my DX79TO? And for 10.12?

    Reply

Leave a Reply

Your email address will not be published. Required fields are marked *

Time limit is exhausted. Please reload the CAPTCHA.

About Andrew Kern