About:

Today Apple has released Mac OS X 10.11.5. There is no know issues under this update for Hackintoshes. The update can be downloaded here.

X79 users will have to install the patched AICPM.Kext found on the x79 DMG (As needed) and patch AppleGraphicsDevicePolicy.Kext (under Mac-F60DEB81FF30ACF6 set Config1 to None). Boot with: nv_disable=1 to boot into the system prior to patching the driver.

Nvidia GPU users who need the Nvidia Retail Drivers boot with: nv_disable=1 and download the latest release here.

Last everyone will need to re-patch AppleHDA for onboard audio.

28 Comments on "Mac OS X 10.11.5 Released"

  1. Can you add the link to AppleHDA? In Haswell DMG are not up to date. THanks!

    Reply
  2. Tried to update from appstore, but the it did freeze when it was only lasting 7 minutes to finish the update. Now I can boot into OS X and the recover partition gives me a blank screen.

    Reply
  3. hi andrew!

    I need to update my R4E from 10.8.5 to elCapitan.
    did new install-USB with latest clover and OS10.11 installer.
    USB is booting fine, can add Clover args fine, osx installer starts fine till the first graphic screen with disk util selecting etc…
    BUT: keyboard and mouse are not working any more. so I cant go further…..
    seeing the ‘numlock’ light on the keyboard goes off as soon as the clover screen disappears…..
    did’nt find any info on the net that solved that behaviour (tried a lot).
    do you have a hint which component/kext to change from this list or the x79-clover.config:
    AppleACPIPS2Nub.kext
    ApplePS2Controller.kext
    FakeSMC.kext
    lspcidrv.kext
    NullCPUPowerManagement.kext
    Patched_10.7_AppleRTC.kext

    thank you and best regards,
    kurt

    Reply
  4. Is it possible to patch AppleGraphicsDevicePolicy.Kext using Clover on the fly?

    Reply
    • Yes, at least it worked some months ago. There is a thread on IM I started. But why not patching this by SSDT? I.e. (at least for 6,1 SMBIOS) rename the GPU device to “GFX1”. So for example with R4E and R4BE it looks like this (GPU in slot 1): Device (_SB.PCI0.NPE3.GFX1) { …. } Imho this is much easier, cleaner and also survives OS updates. Plus, this also works for the recovery partition.

      Reply
      • Which forum did you started your thread?

        Reply
        • Search at Insanely Mac for “AppleGraphicsDevicePolicy “on the fly” patching”. Both solutions (Clover path by Pike and SSDT solution by cecekpawon) are outlined there. Imho the SSDT method is the one to go! So if you have X79 and use MacPro 6,1 SMBIOS (also might work for other configs), just take the SSDT.aml provided on the RampageDev DMG and search for “Device (GFX0)”. Replace that with “Device (GFX1)” and it should work. (But as I said make sure you have unpatched kext!). Maybe Andrew should consider changing his SSDTs for the new method?

        • Last that I knew the patch via Clover never worked and was only proposed. Also the GFX0 => GFX1 does not work under Mac OS X 10.11.x last I knew. If it does I would gladly change the code in the SSDT.

        • Hey Andrew! Both methods (Clover patch and SSDT) work OK – at least for me – but one should prefer the much more robust SSDT way. I use the SSDT patch style for months now, works very well and also survived the 10.11.5 update without any problems or further intervention. Shilohh has now this method in his guide as well. As I see it this should work for _any_ 6,1 SMBIOS setup. Just try it! On a side note, there is now also an easy fix in case you miss the 2nd stage boot logo, can be done in the same SSDT entry. Can provide details on this if interested.

        • Send me info on the 2nd stage boot logo issue. I have just recently seen this issue in person with my Dual CPU build.

  5. PS: make sure you have UNPATCHED AppleGraphicsDevicePolicy.Kext for this to work, patch is not needed anymore.

    Reply
  6. Is there going to be Skylake instructions/DMG update any time soon? There are a lot of different Guides from other websites but I trust your Guides only! 😉

    P.S. Kaby Lake will be out there soon!

    Thank you!

    Reply
  7. Hello i have a working mackintosh 10.11.15 on gigabyte z170n gaming 5 , i7 6700k 2 sticks ram and gtx titan , my issue is that i cant seem to use nvidia drivers , every time i set them to use nvidia it switches back to OS X drivers. Also does OS X 10.11.15 support display port on OS X drivers or only with nvidia. Thank you

    Reply
  8. I7 6700K need ssdt for speedstep?

    Reply
  9. Hi there. After installing El Capitan on a z79x-ud5h everything is working great except for a strange issue with my graphics. When the computer boots, the bios takes an extra long time to locate gigabyte 750TI black-edition. The monitor will remain black and flash on standby for 30+ seconds until it finally finds it and continues boot. No issues with Yosemite. Any ideas? Thanks

    Reply
    • You need to boot with:

      nv_disable=1

      Then install the Nvidia Retail Drivers and boot with:

      nvda_drv=1

      Message me on Skype if you are still stuck after that.

      Reply
      • That was all done. The freeze is not occuring duing the clover boot, it is freezing before the uefi recognises the graphics card. I feel like something is going wrong when shutting down.

        Reply

Leave a Reply

Your email address will not be published. Required fields are marked *

Time limit is exhausted. Please reload the CAPTCHA.

About Andrew Kern